System Performance Issue

Incident Report for GreatLab Status Page

Resolved

This incident has been monitored and logged.

We apologise for any inconvenience this may have caused.
Posted Apr 01, 2026 - 09:16 UTC

Investigating

We are currently Investigating Issues with performance.

We apologise for any inconvenience this has caused.
Posted Mar 30, 2026 - 20:26 UTC
This incident affected: US Hosting (Platform).