System Performance Speed Issues

Incident Report for GreatLab Status Page

Resolved

We have identified and logged the reported performance issues and are continuing to monitor the situation.

We apologise for any inconvenience this may have caused.
Posted Apr 02, 2026 - 12:49 UTC

Investigating

We are currently Investigating what is causing this issue.

We apologise for any inconveniences this has caused.
Posted Apr 01, 2026 - 15:40 UTC
This incident affected: US Hosting (Platform).