Shipping - Royal Mail issues

Incident Report for GreatLab Status Page

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 13:20 UTC

Investigating

As per our integration partner Royal Mail has some performance issues - https://status.shipengine.com/
Posted Jul 24, 2026 - 09:58 UTC
This incident affected: Integrations (Integrations).