UK - System Performance Issues

Incident Report for GreatLab Status Page

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 06:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 21, 2026 - 06:39 UTC

Monitoring

We have identified and hopefully resolved the issue. We will continue monitoring our UK environment to ensure the issue is fully resolved.
Posted Apr 10, 2026 - 17:54 UTC

Update

We are continuing to investigate the impact to the UK environment.
Posted Apr 09, 2026 - 15:00 UTC

Investigating

We are currently investigating a spiking behaviour causing our servers performance issues.
Posted Apr 09, 2026 - 12:10 UTC
This incident affected: UK Hosting (Platform).